With WordPress’ 3.0.1 release, I figured I may as well update as I had just updated myself to 3.0 this week.

Much to my chagrin , I was confronted with an error when trying to use the built in updater that WP offers. I was presented with this message when entering my login information:

Error: There was an error connecting to the server, Please verify the settings are correct.

Huh? I know my settings are correct. I typed it again, slowly. Still nothing. I SSH’d to my server and began digging a bit. I saw that I had changed permissions on my web directory (who remembers why?). This didn’t hamper my 2.8->3.0 upgrade as I had done it manually, but here I was.

Thankfully, a quick permissions change got me back to the latest and greatest in no time.

skye@skyebook: sudo chown -R www-data:www-data /my/blog/directory/